Issue:

Your AutoCAD drawing file (. dwg) has become damaged or corrupt in some way, showing one or more of the following symptoms:

 

· File will not open.

· File hangs or crashes AutoCAD.

· Slow performance when editing and manipulating the file.

· Error message when opening or when working in the file.

· Some commands do not work or have a considerable delay.

· Unexplained file size increase.

· Display/regen problems.

· Drawing elements missing.

Causes:

· Third-party applications running inside AutoCAD.

· DWG files created or saved by non-Autodesk or non-RealDWG products.

· AutoCAD terminated while saving the drawing.

· Old drawings used repeatedly over the course of years.

· Network anomalies (transmission errors, file locking, latent writing of data).

· Storage media degradation (bad sectors on a hard drive).

· Defective or failing RAM.

· Operating system issues.

· Power surges.

Solution:

Use the following guidelines and instructions to clean, repair, and recover your drawing. 
 

1. Open a blank DWG and run the RECOVER command. Select the problematic file. AutoCAD will attempt to recover the file and open it.

2. Open a blank DWG and run the RECOVERALL command. Select the problematic file. AutoCAD will attempt to recover the file and open it.

3. Look in the same directory where the DWG resides and see if there is a BAK file of the same name. If so, rename the BAK extension to DWG and see if the file can then be opened.

4. Look in C:\Windows\Temp for files with an SV$ extension. If any exist with a similar name to the corrupted DWG file, then rename the extension to DWG and see if it can then be opened.

If the drawing file (DWG) still opens:

Perform the following steps in the order listed:

1. Open the drawing file.

2. Purge Registered Applications (from the command line):

· Type -PURGE.

· "R" for Regapps (registered applications), then Enter.

· "N" when asked to verify each name to be purged, then Enter.

3. Type PURGE at the command line. With all checkboxes checked on, click Purge All.

4. Audit and fix any errors:

· Type AUDIT at the command line.

· "Y" for Yes to fix any errors, then Enter.

5. Save the drawing.

If the drawing persists with problems, try the following steps:

1. Ensure all layers are on, thawed, and unlocked.

2. Detach all external references (XREFs). Double-check that the xrefs do not have circular attachments.

3. Write Block all necessary information in the file out to a new drawing (from the command line):

· Type WBLOCK at the command line.

· Under Source, select "Objects".

· Under Objects, click the "Select objects" icon.

· Use a selection window to choose only the necessary objects from the file (do not simply type ALL).

· Set file path and name, then OK.

4. Open a new blank drawing file.

5. Insert the file created in Step 3 (from the command line):

· Type INSERT at the command line.

· Select the file.

· Uncheck "Specify On-screen" and check "Explode", then OK.

6. Type PURGE at the command line. With all checkboxes checked on, click Purge All.

7. AUDIT and fix any errors.

8. Type SAVEAS and create a new file name.